Blog / Article #45
wampserver 3 me renvoie vers un bon vieux 404 not found malgré une bonne configuration

star

12 Septembre 2016

Wampserver 3 me renvoie vers un bon vieux 404 not found malgré une bonne configuration

auto index apache wamp 404 not found loana grosse truie dégueulasse

Réglage de vhost

J'ai rapidement besoin d'un vhost local qui pointe sur un dossier test, ça pouvait prendre 20 secondes mais ça m'a pris 20 minutes ! Je me suis pris des 404 not found dans les yeux ça m'a énervé gonflé bien saoulé ; bref.... Évidement je check les logs, rien qui déconne, la structure de mon vhost est toujours la même (je la copie d'un vhost a l'autre en fait^^) je me pose vraiment des questions sur ma santé mentale quand je tombe sur ca !

Le module autoindex

Depuis quelques temps apache a évolué et les permissions aussi. Du coup on ne peut plus afficher l'arborescence d'un dossier si le module autoindex n'est pas checké dans wamp. Bien sur j'avais juste créé mes dossiers pour copier coller le path dans mon vhost mais j'avais pas pris le temps de creer un index.php dedans. parce qu'avec un fichier index.php, je ne me prenait pas de 404 , ca marchait très bien.. Moi je cherchais du coté du vhost et des options +Indexes, j'ai même créé un .htaccess dans mon dossier de destination, j'étais perdu^^
Une fois ce module coché dans l'interface apache de wamp, tout a fonctionné comme sur des roulettes!

Si ça peut servir à quelqu'un, ou a moi dans quelques jours, quand j'aurais oublié ^^ bon dev !

Lien qui va bien : module autoindex

Ps: Pour le boudin, je cherchais une image sexy ou amusante et .. je suis tombé sur cette chose immonde.
Banco ! =)


Dis moi que tu m'aimes avec un +1

Auteur de l'article
Retour a la liste